Problème de téléversement

Démarré par draeguob, octobre 09, 2017, 07:11:29 pm

« précédent - suivant »

draeguob

Bonjour à tous,

je viens de télécharger les nouveaux fichiers sur Github et lorsque je téléverse un programme j'ai un message d'erreur :
"Date : Monday 09 October 2017 19:07:15
Heure de la dernière exécution : Monday 09 October 2017 19:06:43

Resultat :
'C:\Users\Tounet\Desktop\ARDUINOarduino_debug.exe' n'est pas reconnu en tant que commande interne
ou externe, un programme excutable ou un fichier de commandes.

The return code: 1"

Je recommencer plusieurs fois le paramétrage du module de communication mais sans succès  >:(

Auriez-vous une idée, un dépannage ? Merci d'avance  :)

SebCanet

Bonjour,
il y a un pb dans le raccourci, il manque une '\'.
Tu as fais "outils -> réinitialiser" ?
Sinon peux tu essayer de rajouter la barre \ au bon endroit ? C:\Users\Tounet\Desktop\ARDUINO\arduino_debug.exe

draeguob

Merci pour ta réponse mais c'est le texte qui m'est renvoyé dans la partie basse de la page du site lorsque je téléverse depuis blockly en utilisant le module de communication.

Je viens de voir aussi que sur le page "supervision de la carte" un message d'erreur s'affiche :"Erreur : connexion à la carte impossible ! Le serveur est-il lancé ? Le serveur semble fermé et le websocket inaccessible."

Avant de télécharger la dernière version de l'IDE, TVB, depuis impossible de téléverser !!! et je ne vois pas la solution ???  ???

draeguob

J'ai réinstaller Mozilla et cela semble fonctionner correctement   :P  J'ai toujours mon message d'erreurs dans l'onglet "Supervision de la carte"

Merci à toi et désolé de vous avoir solliciter pour pas grand chose

A+

SebCanet

Pour la supervision, il faut :

  • avoir téléversé le sketch FirmataPlus dans la carte,
  • avoir lancé le serveur de communication qui assure le dialogue entre la navigateur et la carte (enfin le port série)

Merci de tester.

draeguob

OK, cela fonctionne, merci pour ta réponse.

Dans la série pas de bol :

je viens de télécharger Blockly_AIO via le logiciel de synchro. Quand je lance l'application Blocklyarduino_AIO, j'ai un message d'erreur concernant un fichier "blocklyarduino.ini"

voir photo

Comment résoudre ce problème ? Merci

Bzhtitude

Je crois me souvenir que tous les fichiers sont en lecture seule par défaut, dans les propriétés du répertoire, tu peux décocher "lecture seule" et appliquer aussi aux sous dossiers... c'est bourrin, mais ça débloque.

SebCanet

Mince ! Je bloque sur un moyen pratique de synchro pour éviter d'avoir un télécharger des énormes zip à chaque fois.

draeguob

CA MARCHE !!!  :D  Merci à Bzhtitude, en effet il suffit de décocher la lecture seule  :-*

Et de nouveau un GRAND MERCI à Sébastien pour cet énorme travail que je commence à exploiter avec mes élèves.

J'en profite pour lancer un appel à la communauté : si des enseignants utilisent Arduino et notamment Blocky, il serait peut-être intéressant d'échanger nos pratiques, projets, observations, difficultés, travail avec les élèves, etc...

J'interviens dans un module d'Accompagnement Personnalisé avec des élèves de Terminale TISEC (système énergétique et climatique) en Lycée pro.

Bien à vous tous

SebCanet

Super idée ! Je suis tout à fait pour le partage évidemment.
On peut utiliser le serveur associatif sur lequel j'ai mis Blockly@rduino : https://webcloud.zaclys.com
Ou bien sur mon propre cloud : https://91.161.103.65:444 ; id & mdp : libreduc

Patapain38

février 15, 2020, 03:45:49 pm #10 Dernière édition: février 15, 2020, 03:58:04 pm par Patapain38 Raison : Erreur de frappe
Bonjour,
Tout nouveau sur ce site et démarrant sur Blockly, je suis admiratif de ce gros travail. Mes félicitations.
Alors pour ma part comme j'ai des cartes Léonardo et des cartes shield grove, j'ai conçu des platines d'essai mais je me suis heurté au fait que à chaque fois qu'on trouve sur internet des appli, il manque quelque chose comme par exemple chez Technologies Services ou leur package ne prend en compte que la carte UNO. J'ai donc été enthousiaste lorsque j'ai vu votre travail.
J'ai donc downloadé le package  "Blockly@rduino AIO" mais je rencontre plusieurs pbs.
1) lorsque vérifie un petit programme ou je veux afficher (sur afficheur "grove-LCD RGB backlight V4.0") j'ai l'erreur suivante :

Patapain38

Bon ben excusez moi mais j'ai été trop vite et j'ai validé alors que je voulais prévisualiser, malheureusement je n'arrive pas à modifier car le code de vérification n'est plus pris en compte j'ai changé de code, je l'ai écouté mais il me répète sans arret que le code n'est pas le même que celui affiché. Bon c'est pas grave je continue ici.
Donc j'ai cette erreur en rouge dans la partie "résultats détaillés" : Erreur
Vous auriez une solution par hasard ?
Sinon "SebCanet" je ne peux pas tester ton cloud "https://webcloud.zaclys.com" car l'ID et MDP libreduc ne passe pas.
Merci par avance
Pat

Patapain38

Bon ben j'ai réinstallé et ca marche... mais pas tout
J'ai un afficheur Grove RGB comme ici

J'arrive bien a sélectionner la couleur d'arrière plan mais j'ai tout tenté pour le texte, il n'apparait pas.
Une idée
Ci dessous les blocks
Vous ne pouvez pas voir les fichiers joints de cette section.

fontaine.jp

Salut,
j'ai cette carte et elle fonctionne bien avec ce code :
#include <Wire.h>
#include <rgb_lcd.h>

rgb_lcd lcd;

void setup() {
  lcd.begin(16,2);
  lcd.clear();
  lcd.setRGB(0,0,255);
}

void loop() {
  lcd.setCursor(0,0);
  lcd.print("bonjour");

}
et elle est connectée en i2c ;-)

Patapain38

Salut fontaine.jp et merci pour ta réponse.
J'ai remis les blocs et j'ai obtenu le même code que toi.
Voir ci-dessous les copies d'écran :
1) des blocs,
2) du code correspondant,
3) de la photo de la platine avec l'afficheur.

Comme tu peux le voir sur l'afficheur, la couleur est bonne mais il n'y a pas le texte.
Je vois 2 possibilités :
1) le texte est écrit de la même couleur que le fond
2) les librairies ne sont pas les même.
pour moi ça reste un mystère
J'ai une carte UNO je vais essayer, on verra bien.
A+
Pat