Problèmes MAJ 12/07/2018

Démarré par Bzhtitude, Juillet 12, 2018, 11:21:18 am

« précédent - suivant »

Bzhtitude

Bonjour,

J'ai mis à jour blockly@rduino ce matin... quelques soucis se présentent:

1. Le bouton "valider" lors du choix de la carte peut se cacher...
2. Plus aucun code n'est généré, çà fait le même effet quand aucune carte n'a été choisie...

J'ai fait un petit PDF pour que ce soit plus clair.


SebCanet

Merci, je suis en plein travail dessus  ;D
Le 2 c'est réglé, pour le 1 je réfléchis à l'ergonomie.

Bzhtitude

Oui, j'avais bien vu sur le Github qu'il y avait du remue ménage ;)
Si tu souhaites des retours sur ses modifs ou pas , je peux tester presque en temps réel pour ma config (W10 64).


SebCanet

Salut,
tu peux vérifier tes modifs sur ethernet car il semble que ça déclenche une erreur de type ?
"TypeError: Blockly.Blocks.ethernet_client_begin is undefined"

Merci.

Bzhtitude

Ce bloc n'existe plus ( je l'ai renommé) , il y avait encore un appel dans les typing... c'est reparé en principe.

SebCanet

Ok, j'ai nettoyé et remis sur Github.

toucas

Bonjour ou se cache le .exe dans la version avec les block rf433 ?
Les index n'affiche pas bien les block ou alors il ny a pas la possibilité de televerser le code directement de blockly.
J'utilise actuellement la version 2.7 avec dedans blocklyarduino_AIO.EXE qui fonctionne tres bien mais il ny a pas les rf433

SebCanet

Bonjour,
de quel exe tu parles ? Peux tu envoyer des captures d'écran ?

Pour mettre à jour Blockly@rduino, il suffit de mettre à jour son dossier indépendamment du reste.

toucas

Lol comment on mais des photos sur le forum jai jamais compris

toucas

Je fait un test pour les captures
Actuellement j'utilise cette version https://www.cjoint.com/c/HIph6iuDTgr

toucas

Et la dernière version qui m'intéresse https://www.cjoint.com/c/HIph5NJPg1r comment fusionner les 2 pour avoir les block rf433 et pouvoir televerse directement de blockly dans arduino ?
?

SebCanet

Ok, alors depuis la capture 2, il y a Blockly@rduino (c'est à dire l'ensemble de pages web) dont tu vas copier tout le contenu dans le dossier wwwBLockly@rduino de la capture 1.
Tu supprimes son contenu par le nouveau contenu et normalement c'est à jour.
Merci des tests.

toucas

Un grand merci a toi lol ca fonctionne nickel juste je ne trouve pas les block rf433 pourtant je les vois bien dans le dossier blocks

toucas

Ok donc après plusieurs test ou je voie bien les block rf433 et le televersement ne fonctionne pas ou jai pas les block rf433 et la jai bien le televersement pas moyen d'avoir les 2. Et avec le plugin ide jai juste un écran blanc et rien d'autre. Ou c'est que je me trompe ?

SebCanet

Quelle est ton erreur de compilation ?
As tu installé une bibliothèque pour ça ?