Sorry, you must be logged in to use the shoutbox!

Auteur Sujet: Perte du port com  (Lu 54 fois)

EPh

  • Newbie
  • *
  • Messages: 20
    • Voir le profil
Perte du port com
« le: janvier 09, 2019, 10:44:47 pm »
Salut à tous,

Après plusieurs semaines d'utilisation, la version electron me donne presque entière satisfaction.

1- Subsiste un pb la perte du port com.
Après investigation je me suis aperçu que cela survenait après une première utilisation suite à l'ouverture d'un fichier programme. Pour résoudre le pb il faut quitter débrancher la carte, relancer et reouvrir le programme.
Avez vous de tels pbs ?

2- L'enregistrement de la config ne fonctionne pas, j'ai pallier ce pb en mifiant le fichier json

3-une question pratique : comment doit on procéder pour intégrer une librairie (la ligne dans la rubrique arduino existe) mais je ne sais pas ou doit on l'enregistrer ?

4-une question théorie : peut on lancer deux ou plusieurs parties de programme qui se déroulent simultanément (multitache) ? Si oui comment.

Merci.
@+ Philippe

SebCanet

  • Administrator
  • Sr. Member
  • *****
  • Messages: 487
    • Voir le profil
Re : Perte du port com
« Réponse #1 le: janvier 10, 2019, 10:51:38 am »
Salut,
1. effectivement le système de détection des ports COM de la version Electron ne m'apporte pas satisfaction...mais je n'ai pas du tout le temps de bosser dessus avant février car il faut vraiment se poser pour tester (pas juste régler un truc en 10mn).

2. argh
3. à documenter....c'est dans le dossier \sketchbook\libraries
4. les cartes Arduino ne sont pas multitâche. Il y a cependant une bidouille avc certaines bibliothèque, mais je n'ai pas eu le temps de les intégrer (https://github.com/technologiescollege/Blockly-at-rduino/issues/46).

A+