Probleme version du 31 décembre 2019

Démarré par hmenguy, Janvier 09, 2020, 11:20:12 am

« précédent - suivant »

hmenguy

Bonjour

Je viens de tester la nouvelle version de blocklyArduino_electrified et cette version ne permet pas d'utiliser les librairies fournies dans le répertoire sketchbook/libraries/.

En testant en ligne de commande, le résultat de la commande arduino-cli lib list qui permet de lister les librairies prises en compte par le compilateur, nous retrouvons les éléments du nouveau répertoire arduino/libraries

En déplaçant toutes les librairies contenues dans le répertoire sketchbook/libraries/ vers le nouveau répertoire, l'application fonctionne correctement.

Merci

SebCanet

Bonjour,
l'idée de cette version autonome et portable est justement de ne pas avoir besoin de l'EDI Arduino, d'avoir un système auto suffisant.
Donc pour installer des bibliothèques il faut exécuter la commande documentée ici : https://github.com/arduino/arduino-cli#add-libraries

Ca reste en local, dans un sous dossier de Blockly@rduino.

Bons tests.