Voir les contributions

Cette section vous permet de consulter les contributions (messages, sujets et fichiers joints) d'un utilisateur. Vous ne pourrez voir que les contributions des zones auxquelles vous avez accès.

Messages - EPh

1
Salut à tous,

Un pb de librairies existait avec l'ancienne version de AIO.
Sébastien est intervenu, merci à lui pour sa réactivité.
Avec la version téléchargée, le 24/05/2019 tout fonctionne à merveille.
Bons tests.
2
HHEEELLLPPP !!! / Re : Perte du port com
Avril 11, 2019, 10:45:03 pm
Salut Sébastien,

Merveilleux travail. Après une semaine de tests cela fonctionne bien.
L'idée de transparence pour avoir un espace de travail plus grand est trés intéressante.
La perte du port n'être peut être pas à imputer à Blockly mais à la détection par w7 de la carte. Je vais approfondir.

Petits bogues que j'ai repéré sur la version téléchargée aujourd'hui :
- les photos
GROVE - les actionneurs, il manque les photos des contrôleurs de moteur
GROVE - communication, il manque les photos utilisation arduled

- quelques fichiers exemples comportent des anomalies et le code (avec les jumelles) est vide ex: commander un servomoteur avec un potentiomètre    mais ce n'est pas le seul à comporter ce pb.


En conclusion :
J'ai déployé sur tous mes postes et c'est vraiment super.
@+ Philippe

PS :
Une question annexe : pourquoi avoir mis la sélection du port, le téléversement du microprogramme, l'autorisation de supervision dans la barre des taches et non pas l'interface ?

Une remarque annexe : sur le forum lorsque l'on clique sur NEWS, AMELIORATIONS A APPORTER, ... cela ne mène à rien.
3
HHEEELLLPPP !!! / Re : Perte du port com
Avril 02, 2019, 10:48:03 pm
Salut,

1-Les premiers tests de AIO sont encourageants par rapport au port COM (testé sur W10 pro perso). Je testerai au collège en fin de semaine.

2-La supervision ne fonctionne pas. Elle se lance mais les deux flèches restent blanches et aucun échange n'est possible.

3-J'ai remarqué un autre petit pb dans :
GROVE - les actionneurs, il manque les photos des contrôleurs de moteur
GROVE - communication, il manque les photos utilisation arduled

Après les tests sur des W7 profil élève, je te tiens au courant.

@+ Philippe

PS : quelle est la différence entre électron et aio ?

4
HHEEELLLPPP !!! / Re : Perte du port com
Mars 31, 2019, 09:34:47 pm
Salut Sébastien,

Je fonctionne avec une version de fin 2018. Mon pb est identique : perte régulière du port com.

Dans ton message tu émettais l'éventualité de travailler sur la résolution de ce pb.
J'ai vu sur l'espace de téléchargement que tu en étais à : core upgrade to v1.3.0.
En pleine production je n'ai pas osé franchir le pas vers celle-ci.

Est ce que cette version résout ce pb ?

@+ Philippe


5
HHEEELLLPPP !!! / Perte du port com
Janvier 09, 2019, 10:44:47 pm
Salut à tous,

Après plusieurs semaines d'utilisation, la version electron me donne presque entière satisfaction.

1- Subsiste un pb la perte du port com.
Après investigation je me suis aperçu que cela survenait après une première utilisation suite à l'ouverture d'un fichier programme. Pour résoudre le pb il faut quitter débrancher la carte, relancer et reouvrir le programme.
Avez vous de tels pbs ?

2- L'enregistrement de la config ne fonctionne pas, j'ai pallier ce pb en mifiant le fichier json

3-une question pratique : comment doit on procéder pour intégrer une librairie (la ligne dans la rubrique arduino existe) mais je ne sais pas ou doit on l'enregistrer ?

4-une question théorie : peut on lancer deux ou plusieurs parties de programme qui se déroulent simultanément (multitache) ? Si oui comment.

Merci.
@+ Philippe
6
Version BlocklyArduino_AIO-master :
Exact la supervision (entrée et sortie) en passant par l'icône en bas fonctionne. Le pilotage d'un servo ne fonctionne pas.
La bascule vers le mode de fonctionnement normal demande un redémarrage et la suppression Blockly@rduino.json pour accéder au téléversement en mode normal.


Version BlocklyArduino_electrified-master :
J'ai essayé de faire le tour avant d'estampiller version 1
Sur l'écran d'accueil ne fonctionne pas
- la loupe +
- la loupe -
- gérer les exemples (amène sur une fenêtre sans possibilité d'action)

Sur l'écran agrandi ne fonctionne pas
- gérer les exemples ouvre sur une deuxième fenêtre blockly
- aide vidéo et wiki
- la loupe +
- la loupe -

Lorsque l'on bascule de l'écran agrandi à l'écran d'accueil perte du port com4, il faut redémarrer

Tester sur W10, je verrai mardi dans mon établissement sur W7.
@+ Philippe
7
Salut,

Suite à ton message :

Test version electron :
- tout est fonctionnel (testé avec bibliothèque servo, et lcd)
- seul la supervision mais c'est normal pas encore active

Test version C:\BlocklyArduino_AIO-master

Cas n°1 : utilisation traditionnelle en création - téléversement de programme cela fonctionne
Cas n°2 : utilisation de la supervision HS. Cela ne fonctionne pas (téléversement du microprogramme impossible)et de plus ensuite rien n'est possible (utilisation traditionnelle). Pour pouvoir réutiliser le logiciel en programmation-téléversement il faut supprimer le fichier Blockly@rduino.json.

J'ai fait un test en lançant blockly_arduino_communication.exe, en televersant firmata plus, puis en cliquant sur communication et après en lançant  C:\BlocklyArduino_AIO-master, là la carte est reconnue et la supervision fonctionne.

Semble t'il cela provient du téléversement du microprogramme qui ne se fait pas ou mal ?
Mes compétences s'arrête là.
Bonnes recherches.
8
Salut,

Pbs réglés :
- L'ouverture des B@ et xml quelque soit la fenêtre cela fonctionne.
- L'ouverture des exemples fenêtre réduite fonctionne.

Pbs non réglés :
- L'ouverture des exemples fenêtre agrandie ne fonctionne pas (voir vidéo exemples mail).
- Le téléversement avec des bibliothèques (ex : servo) semble posé un pb de chemin d'accès (voir video téléversement mail).
- La supervision n'est pas grisée, reste donc accessible mais ne fonctionne pas toujours pb de connexion à la carte.

Question :
- le .INI à modifier pour éviter le paramétrage de démarrage se trouve où ?

Tu avance à grands pas, je ne sais comment te complimenter pour ce travail énorme.

@+ Philippe

9
News / Re : Intégreation en plugin de l'EDI Arduino
Octobre 28, 2018, 09:08:14 pm
Salut Sébastien,

Quelques remarques sur la nouvelle version.
1-C'est dommage que le menu ETAPE - CODE qui permettait de téléverser, et ETAPE - BLOCK qui permettait de refaire apparaitre les blocks aient disparu. Il faut maintenant passer par les lunettes et puis upload. Pour les élèves cela était plus évident.
2-Le nouveau format de fichier *.B@ est problématique. Tous les anciens programmes *.xml ne s'ouvrent plus directement.
3-Je ne sais pas si c'est un pb du logiciel ou de mon poste mais de temps en temps des fermetures intempestives.
4-Toujours même pb lorsque l'on clique sur A propos. Le lien du forum et d'autres fonctionnent dans une fenêtre java dont on ne peut plus sortir et on perd tout (pb avec les élèves qui n'ont pas sauvegardé). Le lien github ne s'ouvre pas correctement et le wiki pas du tout.


Beau travail.
@+ Philippe
10
News / Re : Intégreation en plugin de l'EDI Arduino
Octobre 15, 2018, 06:31:51 pm
Je renvoie le fichier sans accent !!!
11
News / Re : Intégreation en plugin de l'EDI Arduino
Octobre 15, 2018, 06:29:40 pm
Salut à tous,

Je viens d'installer dans l'ide arduino 1.8.3 l'updater (récupéré à cette adresse https://github.com/technologiescollege/BlocklyArduinoIDEPlugin ) je l'ai dézzipé dans le dossier Tools.
Blockly semble fonctionner pour le téléversement.
Seul petit hic dés que je souhaite mettre à jour avec l'updater il m'indique un message d'erreur (voir doc joint).
De plus la capture d'écran ne fonctionne pas.

Auriez vous une solution ?
@+ Philippe
12
Bonjour à tous,

J'ai trouvé ce block (voir image)
Où doit on placer le dossier de la librairie dans l'arborescence blockly@arduino pour pouvoir l'utiliser ?
ex : DS1307.h ou autre

Merci par avance.
@+ Philippe
13
Salut S. ,

Sur tes conseils j'ai essayé de télécharger le logiciel de synchro mais lorsque je l'ouvre il me demande un mot de passe.
Ou le trouve t'on ?
Merci.

@+ Philippe

14
Peut être je me trompe, mais les photos données dans un post précédent n'ont pas été intégrées.

J'ai téléchargé à cette adresse : https://github.com/technologiescollege/Blockly-at-rduino.

Pb à nouveau ce soir le téléversement ne fonctionne plus. Nous sommes de tout coeur avec toi dans la résolution de ce problème.
Bon courage.
@+ Philippe
15
Salut,
Merci.
Attention il manque dans tous les modules ajoutés (les miens, plus d'autres moteur,... les photos)

J'ai modifié le blocks_typing.js

// ************************************************************ \blocks\blocks_typing.js *************************
// ******************************************************************* ajouté ********************************
Blockly.Blocks.grove_bluetooth_slave_AT.getBlockType = function() {
   return Blockly.Types.NUMBER;
};
Blockly.Blocks.grove_FIN_COURSE.getBlockType = function() {
   return Blockly.Types.BOOLEAN;
};
Blockly.Blocks.grove_RECEPTEUR_IR.getBlockType = function() {
   return Blockly.Types.BOOLEAN;
};



Peux tu me dire si cela est bon ?

Par contre pour l'émetteur je ne sais pas quoi mettre.

@+ Philippe