Some Issues

Démarré par Ernie, Janvier 05, 2020, 03:56:29 AM

« précédent - suivant »



First of all thank you very much for your great work! Blockly@rudino seems to be exactly what I was looking for. Unfortunately, I have some issues with it, hopefully you can help:

1. Blocks Factory Window
When I try to start the blocks factory, the opening window is nearly empty (just the 2 boxes of the Block Definition and Generator Stub plus the string "LTR" at the top - nothing else).
Have you any idea how to fix this?

2. Blocks Factory load and save option
As intermediate workaround I tried to start the blocks factory via the link "" where the blocks factory seems to load correctly, but I didn't found any option to load or save the blocks I created.
Have I missed something?

3. Issue with loading projects
It happed to me some times that a previously saved and already successfully loaded project did not load anymore. When loading, the blocks just showing up temporarily for 1 second, then they disappear.
I after a while, and trying different things it word again, but I could not yet figure out the systematics how to fix this temporary issue (a program restart or even killing the task does not help).
Do you have any solution to fix this issue or at least to reset everything when it appears?

3. Issue with starting BlocklyArduino AIO
Currently BlocklyArduino_AIO.exe is not starting anymore. The small start-up window shows up for 4 seconds, then it disappears. At the same time the task disappears from the Windows task list.
When I start Blockly@rduino.exe from the \tools\B@electron sub-directory the program starts correctly.
Any Idea?


very happy that my soft is useful and could help.
I'll try to answer:

1. Did you try this URL: ? Is it online or offline version ?

2. You cannot save a block as it, you have to create needed file (one for drawing blocks, block definition) and one for code behin the block (generator stub). And follow tutorials to fill some other files...

3. It seems to be a Blockly issue, but do you do any specific manipulation ? modifying windows ?

4. Really problem when I launch it on my PC. Did you try delete 'Blockly@rduino.json', 'Blockly@rduino.ini' and Blockly@rduino_AIO.exe.manifest ?



Thank you very much for your feedback.

1. Issue #1 (block factory window) always appears with the offline version (I cloned the Github repository and started  the BlocklyArduino_AIO.exe). The online versions works so far.

2. I haven't tried it to create new blocks so far but had expected to find at least one button in the block factory to acknowledge a new block is ready. Specifically, with the experience of #1 and the fact that the Google online app has "save block" as well as library command buttons, I thought that I had an issue with missing  graphic elements in the blocky@rduino block factory online version as well.
So far I also could not find any good tutorial to create blocks. Do you have a link?

3. This is also only an issue with the offline version I direct loaded from Github (see 1), no manipulations or mods.
Bases on my trials, it just seems it is not as persistent as #1, sometimes I could load a project.
Interestingly, if a project does not load correctly, there is also no question popping up whether to replace the current blocks, although I can already, for about 1 second, see the blocks in the working window, before they disappear again with a kind of refresh of the entire application window.
Example projects load correctly.

4. In the meantime, I could fix it by re-cloning the Github repository. Probably it would have been sufficient to delete the file you mentioned.


1. I'll try to correct it ASAP.

2. I need to update 'Arduino' block factory with Google Blockly new features. You should have a look at this video:, use this factory:, save code in file in right folders and try to fill some files: (sorry it's in French).

3. need more details to reproduce bug...

4. Good!