• Welcome to Forum des utilisateurs de Blockly(s). Please login or sign up.
 
décembre 02, 2021, 10:24:59 am

Messages récents

Pages 1 ... 8 9 10
91
HHEEELLLPPP !!! / Re : Problème de téléversement
Dernier message par SebCanet - février 23, 2020, 12:15:55 pm
Salut,
à propos des bibliothèques c'est un vrai pb, entre les mises à jour et les variantes, c'est vite galère.
Normalement, j'entretiens un EDI qui contient les bonnes bibliothèques : https://github.com/technologiescollege/arduino

A vérifier mais ça doit passer.
Bons tests.
92
HHEEELLLPPP !!! / Re : Problème de téléversement
Dernier message par fontaine.jp - février 22, 2020, 09:50:49 am
Difficile de répondre, il faudrait le code complet , tous les messages d'erreur, le câblage et tu utilises quel IDE ? La bibliothèque Ultrasonic est installé ? si oui où ?
Merci.
93
HHEEELLLPPP !!! / Re : Problème de téléversement
Dernier message par Patapain38 - février 20, 2020, 09:18:56 pm
Re-bonjour fontaine.jp,
Suite de mon pb, alors avec la carte UNO ça marche impec.
Puis j'ai trouvé que, avec la carte Léonardo, en basculant le switch qui est a coté du connecteur A0 sur le shield Grove pour passer de 3,3v en 5V, et bien ça marche.
Quelle galère !!!
Maintenant j'ai un autre problème :
J'ai voulu tester le capteur ultrason Grove ça ne marche pas.
Lors de la validation il m'indique "error: 'class Ultrasonic' has no member named 'MeasureInCentimeters'"
C'est la ligne : const int Distance = ultrasonic_2.MeasureInCentimeters();
qui pose pb.
Je l'ai remplacé par : const int Distance = ultrasonic_2.read(); la validation n'a plus trouvé de pb. Mais ça n'affiche rien. Je l'ai mis sur le connecteur D2 et je ne sais pas s'il faut le mettre sur une analogique (A2 par ex.).
Enfin c'est galère, Sur mBlock c'est pareil les librairies c'est pas clair et y a pas d'aide qui pourrait donner des explications sur l'utilisation de chaque capteur ou actionneur.
Bref si vous avez des suggestions car je commence à fatiguer...
Sinon je vais regarder les liens que tu m'as donné
Au fait 200€ c'est pour tout le clg, on est 2 profs ca fait donc 100€ chacun on va vraiment pas loin avec ça...
Merci
Pat
94
HHEEELLLPPP !!! / Re : Problème de téléversement
Dernier message par fontaine.jp - février 20, 2020, 12:14:51 am
je viens de trouver que le brochage i2c de la carte uno et léonardo était différent --> https://www.locoduino.org/spip.php?article77
Je n'utilise pas l'adaptateur grove mais le câble grove <--> 4 broches Mâle ou femelle ; ça peut venir de là ?
95
HHEEELLLPPP !!! / Re : Problème de téléversement
Dernier message par fontaine.jp - février 19, 2020, 11:49:44 pm
Salut, il y a ça --> http://www.centralmedia.fr/robotique/04-cartes-a-microcontroleur/2-cartes-compatibles-arduino/carte-uno-r3-compatible-arduino-atmega328p-ch340g-unor3,g1_319_321p44425.html
Pour moins de 9€ TTC il y a un clone de la uno.
ET ici --> https://www.gotronic.fr/art-afficheur-lcd-i2c-grove-104020112-28879.htm
tu as l'afficheur lcd sans le rvb pour 6€5.
Tu en prends 10 ou 15 et tu fais des des groupes de 2 ou 3.
Ce sont les sites les moins chers et officiels.
Comme je n'ai pas de carte Leonardo je ne peux pas vérifier ce qui ne va pas 😉
96
HHEEELLLPPP !!! / Re : Problème de téléversement
Dernier message par Patapain38 - février 19, 2020, 10:05:28 pm
Re-bonjour fontaine.jp et à tous aussi,
Je viens de tester avec la carte UNO et ça marche impec, j'ai même écris sur les 2 lignes.
Donc mon pb n'est pas résolu car j'ai 7 platines d'essai avec des cartes léonardo (officielles).
La carte UNO est ma carte perso (générique) et je n'en ai qu'une.
Je ne veux pas faire pleurer dans les chaumières car il y a surement plus mal loti que moi mais je me vois mal acheter 7 cartes UNO alors que je n'ai que 200€ de budget pour 450 élèves et qu'on m'interdit d'acheter en chine, sur Amazon ou ailleurs, c'est TS ou A4 obligatoire (donc bien plus chères).
Si vous avez une solution je vous bénirai, voir ferai bruler un cierge.
Trève de plaisanterie, c'est gonflant car j'y ai passé pas mal d'heure sur ce pb de m.....e.
Au plaisir de vous lire.
Pat
97
HHEEELLLPPP !!! / Re : Problème de téléversement
Dernier message par Patapain38 - février 19, 2020, 09:32:35 pm
Salut fontaine.jp et merci pour ta réponse.
J'ai remis les blocs et j'ai obtenu le même code que toi.
Voir ci-dessous les copies d'écran :
1) des blocs,
2) du code correspondant,
3) de la photo de la platine avec l'afficheur.

Comme tu peux le voir sur l'afficheur, la couleur est bonne mais il n'y a pas le texte.
Je vois 2 possibilités :
1) le texte est écrit de la même couleur que le fond
2) les librairies ne sont pas les même.
pour moi ça reste un mystère
J'ai une carte UNO je vais essayer, on verra bien.
A+
Pat
98
HHEEELLLPPP !!! / Re : Problème de téléversement
Dernier message par fontaine.jp - février 16, 2020, 04:36:17 pm
Salut,
j'ai cette carte et elle fonctionne bien avec ce code :
#include <Wire.h>
#include <rgb_lcd.h>

rgb_lcd lcd;

void setup() {
  lcd.begin(16,2);
  lcd.clear();
  lcd.setRGB(0,0,255);
}

void loop() {
  lcd.setCursor(0,0);
  lcd.print("bonjour");

}
et elle est connectée en i2c ;-)
99
HHEEELLLPPP !!! / Re : Problème de téléversement
Dernier message par Patapain38 - février 15, 2020, 09:26:04 pm
Bon ben j'ai réinstallé et ca marche... mais pas tout
J'ai un afficheur Grove RGB comme ici

J'arrive bien a sélectionner la couleur d'arrière plan mais j'ai tout tenté pour le texte, il n'apparait pas.
Une idée
Ci dessous les blocks
Vous ne pouvez pas voir les fichiers joints de cette section.
100
HHEEELLLPPP !!! / Re : Problème de téléversement
Dernier message par Patapain38 - février 15, 2020, 04:05:18 pm
Bon ben excusez moi mais j'ai été trop vite et j'ai validé alors que je voulais prévisualiser, malheureusement je n'arrive pas à modifier car le code de vérification n'est plus pris en compte j'ai changé de code, je l'ai écouté mais il me répète sans arret que le code n'est pas le même que celui affiché. Bon c'est pas grave je continue ici.
Donc j'ai cette erreur en rouge dans la partie "résultats détaillés" : Erreur
Vous auriez une solution par hasard ?
Sinon "SebCanet" je ne peux pas tester ton cloud "https://webcloud.zaclys.com" car l'ID et MDP libreduc ne passe pas.
Merci par avance
Pat
Pages 1 ... 8 9 10