Menu

Voir les contributions

Cette section vous permet de consulter les contributions (messages, sujets et fichiers joints) d'un utilisateur. Vous ne pourrez voir que les contributions des zones auxquelles vous avez accès.

Voir les contributions Menu

Messages - vahiny

#1
Citation de: SebCanet le Mars 20, 2018, 04:56:10 PM
As tu choisi une carte ?
Le système de validation du bloc du haut vérifie par rapport à la carte déclarée. Dans l'autre cas c'est libre.
2 mécaniques en prévision de 2 ergonomies...que je n'ai pas pris le temps de faire....

Effectivement.... Je n'avais pas choisi la carte! :P Merci pour le déblocage! ;)
#2
Citation de: vahiny le Mars 20, 2018, 02:52:04 PM

Par exemple ici, j'utilise le module grove: je rentre la valeur de l'entrée de l'interrupteur : 3 qui apparaît bien dans le programme en c++



Lorque je valide, le 3 disparaît dans le bloc et dans le programme c++. Ce bug apparaît dans tous les capteurs grove

#3
Par exemple ici, j'utilise le module grove:


http://nsm09.casimages.com/img/2018/03/20//mini_18032001233123908415622372.jpg


http://www.casimages.com/img.php?i=18032001233123908415622372.jpg


Je rentre la valeur de l'entrée de l'interrupteur : 3 et voici ce qu'il se passe lorsque je valide

http://www.casimages.com/img.php?i=18032001233423908415622373.jpg
#4
Super le plugin!

Pour le moment presque toutes les fonctions marchent sauf avec les détecteurs et capteurs. Quand je change ou que j'entre une valeur pour attribuer une entrée digitale, ça ne fonctionne pas....

Par exemple avec l'interrupteur "grove" impossible de lui attribuer une entrée.

Cordialement
Jerome

#5
HHEEELLLPPP !!! / Code bender ça fonctionne toujours?
Février 20, 2018, 02:04:23 AM
Bonjour,

Mes élèves ont appris à utiliser Blockly avec codebender.

J'ai remarqué aujourd'hui que l'ultrason grove ne fonctionnait pas..... Apparemment la librairie n'a pas l'air accessible.

J'ai essayé de regarder la liste des librairies sur codebender; j'ai ce message :

Sorry! The library list could not be fetched.

Si quelqu'un a une piste?

Cordialement Jerome
#6
Citation de: SebCanet le Novembre 20, 2017, 07:18:58 PM
Version 3.1 (après la 3.0) qui évite de subir trop de conneries...
Normalement ça règle les pb de hors ligne cités précédemment.

Pour boucler il me faut aussi des experts Python + javascript, tu as ça en stock ?  ;D

j'ai bien peur d'avoir surtout desbons bidouilleurs en stock!  :P

Quels sont les points à vérifier pour boucler?

Je teste pour voir si ta dernière mouture tourne proprement. @+
#7
Citation de: SebCanet le Novembre 19, 2017, 01:43:59 PM
Super ! Merci du diagnotic ! Ca vient surement du processus qui vérifie s'il existe une nouvelle version de Blockly@rduino sur Github.
Je regarde ça rapidement.

Super! Si tu as besoin d'un coup de main, j'ai 2 collègues qui se débrouillent en programmation; je peux solliciter leur aide.
#8
Citation de: SebCanet le Novembre 17, 2017, 05:30:04 PM
Super !
Le principe  est un peu délicat car je ne suis pas développeur professionnel et que mon code n'est pas bien protégé/vérifié, ça manque de procédures de contrôle que je ne maîtrise pas. Si quelqu'un a des connaissances qui s'y connaissent en C++ ou en Electron, voire des stagiaires, je suis preneur !

Bons tests, merci d'avance pour les remontées.

Bon, j'ai refait des tests. J'ai trouvé le bug. Lorsque je suis connecté à internet, ça fonctionne nickel.

Quand je me met en mode avion, l'erreur "n'est pas une valeur entière correcte" revient.

Au collège ça ne fonctionne pas non plus , je me demande si ce n'est pas la demande d'accès à "paypal" qui provoque cette erreur.
#9
Citation de: vahiny le Novembre 16, 2017, 07:58:01 PM
Citation de: SebCanet le Novembre 15, 2017, 07:23:15 PM
Pour repartir à 0 et faire des tests :

  • à la racine il ne doit rester que "blocklyArduino_AIO.exe" ET "label.xml" (vc_redist.x86.exe n'est utile qur pour des versions de Windows auxquelles il manque cette mise à jour)
  • dans le dossier "tools", supprimer les fichiers *.bat pour forcer Blockly@rduino à les récréer

Pour que ces fichiers soient recréés correctement, c'est à dire avec VOS paramètres :

  • faire un clic droit sur l'icone et choisir "Outils -> (Ré)initialiser les paramètres",
  • quitter en fermant le navigateur,
  • relancer

Ca devrait être bon. J'ai pu reproduire l'erreur et la régler ainsi. J'essaierai de la corriger...quand j'aurai du temps.
Merci de vos retours.

Bonjour merci pour les infos!

Ca fonctionnement carrément mieux avec ta procédure, j'ai accès au clic droit sur l'icône maintenant.

Par contre le téléversement ne fonctionne pas (j'ai bien le port com de la carte qui s'affiche avec le clic droit), le message suivant apparaît:

'C:\AIOarduino_debug.exe'  n'est pas reconnu en tant que commande interne ou externe, un programme excutable ou un fichier de commande.
The return code : 1


@+

Finalement après avoir récupéré la version "proprement télécharger" et appliqué la procédure: ça fonctionne très bien! Merci pour le travail, je vais tester cette version avec mes élèves et certainement en stage avec les enseignants.
#10
Citation de: SebCanet le Novembre 15, 2017, 07:23:15 PM
Pour repartir à 0 et faire des tests :

  • à la racine il ne doit rester que "blocklyArduino_AIO.exe" ET "label.xml" (vc_redist.x86.exe n'est utile qur pour des versions de Windows auxquelles il manque cette mise à jour)
  • dans le dossier "tools", supprimer les fichiers *.bat pour forcer Blockly@rduino à les récréer

Pour que ces fichiers soient recréés correctement, c'est à dire avec VOS paramètres :

  • faire un clic droit sur l'icone et choisir "Outils -> (Ré)initialiser les paramètres",
  • quitter en fermant le navigateur,
  • relancer

Ca devrait être bon. J'ai pu reproduire l'erreur et la régler ainsi. J'essaierai de la corriger...quand j'aurai du temps.
Merci de vos retours.

Bonjour merci pour les infos!

Ca fonctionnement carrément mieux avec ta procédure, j'ai accès au clic droit sur l'icône maintenant.

Par contre le téléversement ne fonctionne pas (j'ai bien le port com de la carte qui s'affiche avec le clic droit), le message suivant apparaît:

'C:\AIOarduino_debug.exe'  n'est pas reconnu en tant que commande interne ou externe, un programme excutable ou un fichier de commande.
The return code : 1


@+
#11
Citation de: SebCanet le Octobre 15, 2017, 07:24:17 PM
Supprime le fichier ini et le fichier bat, puis dans 'outils -> réinitialiser les paramètres' pour éviter d'avoir les pb de chemin.

Bonjour,

J'ai un problème semblable. Çà ne démarre pas!
Si je supprime "blocklyarduino.ini" --> Blockly arduino démarre pas le module de communication.

J'ai remplacer plusieurs fois le fichier .ini et le rDuino_uploader.bat.... Mais j'ai toujours des bugs....

Comment faire  'outils -> réinitialiser les paramètres' ? Le clic droit sur le module de communication ne fonctionne pas chez moi.

Une idée? Merci!
#12
News / Re : v1 de Blockly@rduino_AIO
Janvier 15, 2017, 03:52:20 PM
2 jours que je télécharge... Je suis toujours pas arriver au bout....  :-\
#13
La librairie (duino edu) de l'IDE d'arduino fonctionne plutôt bien avec la fonction ".mesurer(1)" au lieu de ".measureincm" dans blockly.


#include <Ultrasonic.h>

//libraries at http://duinoedu.com/dl/lib/grove/EDU_Ultrasonic_Grove/
Ultrasonic monUltrasonic_pin2(2);

void setup()
{
}

void loop()
{
  if (( ( monUltrasonic_pin2.mesurer(1) )
#14
L'ultrason dans blockly fait appelle à la bibliothèque <Ultrasonic.h> de codebender.

Cette version fonctionne avec un temps de latence.

Pour des applications robotiques, lorsque l'on a besoin d'un calcul rapide (^par exemple suivre un mur") elle n'est pas toujours exploitable.

#15
Teste cette formule:

(8479.4/(1+1.167*(analogRead(0)))-5

Tu sais fabriquer les blocs?

J'ai aussi la formule l'autre capteur analogique OA41