• Welcome to Forum des utilisateurs de Blockly(s). Please login or sign up.
 

Voir les contributions

Cette section vous permet de consulter les contributions (messages, sujets et fichiers joints) d'un utilisateur. Vous ne pourrez voir que les contributions des zones auxquelles vous avez accès.

Messages - Stéphane17

1
Citation de: SebCanet le octobre 03, 2017, 11:26:34 pm
As tu essayé de télécharger tout Blockly@rduino_AIO ? Tu lances la synchro et télécharge une version propre : https://github.com/technologiescollege/BlocklyArduino_AIO
Non pas encore, mais je checkout depuis GitHub pouravoir les tout derniers fichiers. Je lance AIO maintenant.

Citation de: SebCanet le octobre 03, 2017, 11:26:34 pm
Dans 'outils', as tu réinitialisé les paramètres ou bien recherché l'emplacement de l'EDI Arduino ?
Tout cherché explicitement;

Citation de: SebCanet le octobre 03, 2017, 11:26:34 pm
Quand tu copies le code dans l'EDI Arduino pour faire les étapes manuellement, ça fonctionne ?
Je crois que ça fonctionne avec les élèves car c'était la solution de secours.

Mais je viens de voir un truc...
Le message d'erreur fait référence au dossier C:\Users\utilisateur\AppData\Local\Arduino15 qui existe sur mon petit ordi à moi.
Mais si dans une console je tape
echo %APPDATA%\Local\Arduino15\
il me renvoie
C:\Users\gauste17\AppData\Roaming\Local\Arduino15\
donc un dossier Roaming intercalé.
Or ce dossier Roaming serait pour la gestion des profils itinérants, justement la config des élèves dont le profil se balade sur tous les PC du lycée...

Peut-être fausse piste, mais je creuse.

A++
2
Bonjour,

Citation de: SebCanet le octobre 02, 2017, 11:58:41 pm
Le dossier c:\arduino pointe sur un vieil Arduino (1.5) installé sur le poste à priori, peut être que l'étape va résoudre le pb.

Non, il n'y a jamais d'Arduino 1.5 sur le poste. J'ai installé Blockly sur des postes neufs au printemps dernier (passage de XP à 7), créé le dossier c:\Arduino spécfiquement pour y mettre les 3 dossiers Blockly / IDE 1.8.4 de Github / Communication.

C'est en Seconde, Exploration Sciences de l'Ingénieur (j'ai déjà répondu à mon WHO ARE YOU ;-) )

J'essaie demain de me dépatouiller de ce dossier Arduino15 ... en présence des élèves !
3
Je viens de regarder ce dossier Arduino15 chez moi, et on y trouve 4 fichiers de config. Je vais donc essayer de copier ces fichiers sur les postes lycée.

De plus, j'ai essayé de supprimer ces 4 fichiers chez moi, il en résulte que la boîte de dialogue de choix des blocs est vide, comme le pb de ma première installation évoqué hier sur le forum.

A++
4
HHEEELLLPPP !!! / Blockly en local - Pb téléversement
octobre 02, 2017, 09:26:44 pm
Bonjour,

J'ai installé Blockly + Arduino + Communication du 01/10 depuis github en local sur Windows 7 chez moi.
J'ai enfin compris dans quel ordre utiliser la communication (!).
Ça téléverse, OK, je vois bien le cadre 127.0.0.1 dans Blockly, j'ai eu à valider la demande du pare-feu 2 fois.
(je n'ai pas les blocs Arduino dans Blocs mais c'est pbbm un autre problème).

Maintenant j'ai essayé au lycée, réseau Windows, postes Windows 7 tout frais de qq mois.
Et là ça ne va pas aussi bien. Je lance la comm, Blockly, config UNO, le prog exemple, code arduino, et enfin Téléverser dans l'Arduino ...

D'abord un message d'erreur sur un dossier Arduino15 qui n'existe pas dans mon profil utilisateur (écran ci-joint). Je crée alors ce dossier.
Alors un autre message d'erreur autour de collect2.exe ... (écran ci-joint).

Où chercher alors ?

Merci
5
Nouveaux blocs / Re : Probleme affichage des blocs
octobre 01, 2017, 09:54:28 pm
J'avais la même boîte de dialogue que Karadoc, quasi vide.
J'ai bricolé plein de trucs (installé Firefox ESR, lancé Blockly de septembre 2016, ...) et maintenant j'ai la liste minimale des blocs (7 rubriques de blocs, aucune spécifique à Arduino).
Et quand je repars d'une install vierge, ça fonctionne. Donc mystère... J'ai peur pour mes postes élèves...
6
Nouveaux blocs / Re : Probleme affichage des blocs
octobre 01, 2017, 09:08:00 pm
Bonjour,

Même problème pour moi, sous Firefox 55-56 Windows 32.
Aucun bloc chargé.

Je cherche...
9
HHEEELLLPPP !!! / Re : flash.bat n'existe pas
octobre 06, 2016, 11:09:20 pm
En même temps, quand je tente de "Lancer la communication", j'ai un script lancé qui s'arrête rapidement.
J'ai pu intercepter ce début de texte dans la fenêtre :

pymata_aio Version 2.16 Copyright (c) 2015-2016 Alan Yorinks All rights reserved
.

Initializing Arduino - Please wait... Traceback (most recent call last):
  File "scripts\Lib\site-packages\pymata_aio\pymata_iot.py", line 680, in <modul
e>
    core.start()
  File "C:\Applications\Blockly-rduino-communication-master\scripts\lib\site-pac
kages\pymata_aio\pymata_core.py", line 297, in start
    print("\nArduino Firmware ID: " + firmware_version)
TypeError: Can't convert 'NoneType' object to str implicitly
10
HHEEELLLPPP !!! / flash.bat n'existe pas
octobre 06, 2016, 10:44:59 pm
Bonjour,
J'essaie le triplet Blockly / Arduino / Communication sur un Win7.

Lorsque je lance la commande Outils | Téléverser FirmataPlus dans | Uno
j'ai un message d'erreur "Le fichier 'flash.bat' n'existe pas."
J'ai trouvé 6 fichiers tools\flash_uno.bat, tools\flash_mega.bat, ... mais pas de flash.bat

Pourquoi n'est-il pas trouvé ? Un des 6 fichiers aurait du être copié dans flash.bat ?
Manque librairie py quelconque ? ... ?

Merci
11
HHEEELLLPPP !!! / Re : Blockly sous Windows XP
octobre 06, 2016, 08:09:13 pm
Bon,

J'ai essayé qq bricoles style remplacer des fichiers de Python 3.5 par du 3.4.
Je n'ai plus le message "scripts\python.exe n'est pas une application win32 valide".
Quand je clique sur "lancer la communication", Python semble lancé, l'icône des 2 flèches passe en jaune un peu plus d'une seconde puis se réteint.

Il manque donc qqchose...
Je ne connais pas l'enchainement des scripts python exécutés, et n'ai pas de trace de débugage python (un log qq part ?).
12
Améliorations à apporter / GUI Communication
octobre 04, 2016, 01:52:08 pm
Bonjour,

Excellente "suite" que ce BlocklyArduino.
Excellente aussi la vidéo qui explique l'ensemble https://vimeo.com/180673667

Mais ce qui me déroute le plus, c'est l'interface utilisateur de l'outil de communication.

* Ce menu "Supervision E/S | Téléversement"
- on doute toujours de savoir si le menu affiché est
  . le mode actif affiché (et on ne voit pas le nom de l'autre activable),
  . ou bien celui non actif et activable par ce menu (et le mode actuel n'est pas défini)
Pour cette fonctionnalité de switch entre 2 modes principaux de fonctionnement, je verrais plutôt 2 onglets dans la fenêtre principale, on voit en même temps la bascule entre 2 modes, et les modes disponibles.

* Le menu "Fichier | Localiser les dossiers" : C''est frustrant de définir un paramètre et de ne pas pouvoir (re)vérifier qu'il a été défini. Donc si la volonté sur cet utilitaire est de limiter les fenêtres modales, peut-être peut-on ajouter un 3ème onglet nommé "Paramètres" avec ces infos

* Supervision : difficile de deviner qu'il faille aller chercher le menu "Téléverser Firmata" pour activer la supervision
- Le menu ne devrait être que la sélection du type de carte (cible vérifiable dans l'onglet options), et le téléversement de Firmata ne doit pas être relégué au rang "d'outil" (complémentaire), et doit être un bouton (au texte plus explicite) sur l'écran (l'onglet) de supervision

* Les 2 pages montrent un Arduino en haut, les "connexions" en bas... Comme si la carte Arduino pilotait Blockly et l'IDE. Or c'est le contraire, dans les images "occidentales" habituelles, celui qui a le contrôle (PC) devrait être en haut, la carte Arduino en bas...

Je poste ça pour l'instant, je n'en suis qu'à la moitié de la vidéo...


13
HHEEELLLPPP !!! / Re : Blockly sous Windows XP
octobre 04, 2016, 08:04:21 am
Bonjour,

OK, suite à ton mail Sébastien, maintenant que je sais que tu es l'admin du forum, je continue ici pour partager.

Donc selon https://docs.python.org/3/using/windows.html
Python 3.4 fonctionnait encore sous XP, c'est Python 3.5 qui demande Vista et supérieur.
Donc j'ai de l'espoir pour mes vieux postes de lycéens...
14
HHEEELLLPPP !!! / Blockly sous Windows XP
octobre 02, 2016, 10:09:07 pm
Bonjour,

Je viens de tester BlocklyArduino (récupéré sur GitHub ce jeudi 29 septembre) avec des 2ndes Exploration SI.
J'ai été bloqué car les postes étant sous XP, lorsque je demande une communication, j'ai un message d'erreur "scripts\python.exe n'est pas une application Win32 valide".
Quels sont les besoins minimaux ? Faut-il trouver une autre version de python.exe ?

Merci